re = /^(?:\([\/a-zA-Z0-9_\\-]+\))+$/m
str = '(AAA/)(BBB/)(cc)(\\)
(AAA/)xxxx(BBB/)(cc)
(mystring123/)
(\\mystring123\\)
(g)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end