# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=0x\S*)S/5/gm;t' <<< "0xS4321S3S testS"