const regex = new RegExp('(?<=0x\\S*)S', 'gm')
const str = `0xS4321S3S testS`;
const subst = `5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);