$re = '/(?<=0x\S*)S/m';
$str = '0xS4321S3S testS';
$subst = "5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;