use strict;
my $str = '0xS4321S3S testS';
my $regex = qr/(?<=0x\S*)S/mp;
my $subst = '5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";