#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "console[\s\n\.]+log\([^;]*\);"
Local $sString = " console.log();" & @CRLF & _
" console.log("ok"); " & @CRLF & _
" console. " & @CRLF & _
" log("ok"); " & @CRLF & _
" console " & @CRLF & _
" .log("hey" + " & @CRLF & _
" "guys"); "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")