// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"console[\s\n\.]+log\([^;]*\);").unwrap();
let string = " console.log();
console.log(\"ok\");
console.
log(\"ok\");
console
.log(\"hey\" +
\"guys\"); ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}