re = /console[\s\n\.]+log\([^;]*\);/
str = ' console.log();
console.log("ok");
console.
log("ok");
console
.log("hey" +
"guys"); '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end