package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`console[\s\n\.]+log\([^;]*\);`)
var str = ` console.log();
console.log("ok");
console.
log("ok");
console
.log("hey" +
"guys"); `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}