$re = '/console[\s\n\.]+log\([^;]*\);/';
$str = ' console.log();
console.log("ok");
console.
log("ok");
console
.log("hey" +
"guys"); ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);