using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\b0\.0\b.*$";
string input = @"I want to grab this string 3/6/7 56 0.0 0 0 5 0.00
But not this 3/6/7 56 1.0 0 0 5 0.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}