import re
regex = re.compile(r"^.*\b0\.0\b.*$", flags=re.MULTILINE)
test_str = ("I want to grab this string 3/6/7 56 0.0 0 0 5 0.00\n\n"
"But not this 3/6/7 56 1.0 0 0 5 0.00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")