re = /^.*\b0\.0\b.*$/m
str = 'I want to grab this string 3/6/7 56 0.0 0 0 5 0.00
But not this 3/6/7 56 1.0 0 0 5 0.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end