$re = '/^.*\b0\.0\b.*$/m';
$str = 'I want to grab this string 3/6/7 56 0.0 0 0 5 0.00
But not this 3/6/7 56 1.0 0 0 5 0.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);