const regex = /^.*\b0\.0\b.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\b0\\.0\\b.*$', 'gm')
const str = `I want to grab this string 3/6/7 56 0.0 0 0 5 0.00
But not this 3/6/7 56 1.0 0 0 5 0.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}