using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\bprotein_coding\b.*?exon.*$";
string substitution = @"";
string input = @"protein_coding exon foo bar
foo
protein_coding
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}