re = /^.*?\bprotein_coding\b.*?exon.*$/m
str = 'protein_coding exon foo bar
foo
protein_coding
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result