use strict;
my $str = 'protein_coding exon foo bar
foo
protein_coding
';
my $regex = qr/^.*?\bprotein_coding\b.*?exon.*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";