package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\bprotein_coding\b.*?exon.*$`)
var str = `protein_coding exon foo bar
foo
protein_coding
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}