const regex = new RegExp('^.*?\\bprotein_coding\\b.*?exon.*$', 'gm')
const str = `protein_coding exon foo bar
foo
protein_coding
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);