#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\((?>[^()]++|(?R))*\)"
Local $sString = "stuff(remove(me))" & @CRLF & _
"stuff (inside (nested) brackets) (and (some(are)) here) here" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)