$re = '/\((?>[^()]++|(?R))*\)/';
$str = 'stuff(remove(me))
stuff (inside (nested) brackets) (and (some(are)) here) here
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;