using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?>[^()]++|(?R))*\)";
string substitution = @"";
string input = @"stuff(remove(me))
stuff (inside (nested) brackets) (and (some(are)) here) here
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}