import re
regex = re.compile(r"\((?>[^()]++|(?R))*\)")
test_str = ("stuff(remove(me))\n"
"stuff (inside (nested) brackets) (and (some(are)) here) here\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)