const regex = /\((?>[^()]++|(?R))*\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((?>[^()]++|(?R))*\\)', 'g')
const str = `stuff(remove(me))
stuff (inside (nested) brackets) (and (some(are)) here) here
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);