import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ *if \\(.+\\).*(;)";
final String string = "if (something == something) a;\n\n"
+ " if (another == 3438) a;\n\n"
+ " if (asdfsad == 3425435) a;\n\n"
+ " if (asdsda == 'a') SomeFunction(); // And a comment\n\n"
+ "// Don't match these\n"
+ " if () asdf sdf sd sdfsdf; // Another comment\n\n"
+ " if (assda) {\n"
+ "}\n\n"
+ "don't match this line if (asdfsad == 3425435) a; // Another comment\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}