const regex = /^ *if \(.+\).*(;)/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ *if \\(.+\\).*(;)', 'igm')
const str = `if (something == something) a;
if (another == 3438) a;
if (asdfsad == 3425435) a;
if (asdsda == 'a') SomeFunction(); // And a comment
// Don't match these
if () asdf sdf sd sdfsdf; // Another comment
if (assda) {
}
don't match this line if (asdfsad == 3425435) a; // Another comment
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}