re = /^ *if \(.+\).*(;)/im
str = 'if (something == something) a;
if (another == 3438) a;
if (asdfsad == 3425435) a;
if (asdsda == \'a\') SomeFunction(); // And a comment
// Don\'t match these
if () asdf sdf sd sdfsdf; // Another comment
if (assda) {
}
don\'t match this line if (asdfsad == 3425435) a; // Another comment
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end