import re
regex = re.compile(r"^ *if \(.+\).*(;)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("if (something == something) a;\n\n"
" if (another == 3438) a;\n\n"
" if (asdfsad == 3425435) a;\n\n"
" if (asdsda == 'a') SomeFunction(); // And a comment\n\n"
"// Don't match these\n"
" if () asdf sdf sd sdfsdf; // Another comment\n\n"
" if (assda) {\n"
"}\n\n"
"don't match this line if (asdfsad == 3425435) a; // Another comment\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")