$re = '/^ *if \(.+\).*(;)/im';
$str = 'if (something == something) a;
if (another == 3438) a;
if (asdfsad == 3425435) a;
if (asdsda == \'a\') SomeFunction(); // And a comment
// Don\'t match these
if () asdf sdf sd sdfsdf; // Another comment
if (assda) {
}
don\'t match this line if (asdfsad == 3425435) a; // Another comment
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);