# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/adm-list-table-cell.*?\K[\/ ]*(<span class="del".*?<\/span>)[\/ ]*/$1/g;t' <<< "<td class=\"adm-list-table-cell align-right\"><a href=\"iblock_element_edit.php?IBLOCK_ID=1&type=news&ID=2&lang=ru&find_section_section=-1&WF=Y\" title=\"title\">2</a></td><td class=\"adm-list-table-cell align-left adm-list-table-cell-last\"> / / / / <span class=\"del\">ALL</span> / / / / / / / / / / </td>"