using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"adm-list-table-cell.*?\K[/ ]*(<span class=""del"".*?</span>)[/ ]*";
string substitution = @"$1";
string input = @"<td class=""adm-list-table-cell align-right""><a href=""iblock_element_edit.php?IBLOCK_ID=1&type=news&ID=2&lang=ru&find_section_section=-1&WF=Y"" title=""title"">2</a></td><td class=""adm-list-table-cell align-left adm-list-table-cell-last""> / / / / <span class=""del"">ALL</span> / / / / / / / / / / </td>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}