re = /adm-list-table-cell.*?\K[\/ ]*(<span class="del".*?<\/span>)[\/ ]*/
str = '<td class="adm-list-table-cell align-right"><a href="iblock_element_edit.php?IBLOCK_ID=1&type=news&ID=2&lang=ru&find_section_section=-1&WF=Y" title="title">2</a></td><td class="adm-list-table-cell align-left adm-list-table-cell-last"> / / / / <span class="del">ALL</span> / / / / / / / / / / </td>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result