import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "adm-list-table-cell.*?\\K[/ ]*(<span class=\"del\".*?</span>)[/ ]*";
final String string = "<td class=\"adm-list-table-cell align-right\"><a href=\"iblock_element_edit.php?IBLOCK_ID=1&type=news&ID=2&lang=ru&find_section_section=-1&WF=Y\" title=\"title\">2</a></td><td class=\"adm-list-table-cell align-left adm-list-table-cell-last\"> / / / / <span class=\"del\">ALL</span> / / / / / / / / / / </td>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}