import Foundation
let pattern = #"adm-list-table-cell.*?\K[/ ]*(<span class="del".*?</span>)[/ ]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<td class="adm-list-table-cell align-right"><a href="iblock_element_edit.php?IBLOCK_ID=1&type=news&ID=2&lang=ru&find_section_section=-1&WF=Y" title="title">2</a></td><td class="adm-list-table-cell align-left adm-list-table-cell-last"> / / / / <span class="del">ALL</span> / / / / / / / / / / </td>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)