using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(build.\d).*$";
string input = @"Label Owner Date
---------------------------------------------------- -------------- ----------
ICSExternalGateway-04_MJR-ICSExternalGateway-build.0 Marchen, Keith 2/25/2015
ICSExternalGateway-04_MJR-ICSExternalGateway-build.1 Marchen, Keith 2/25/2015
ICSExternalGateway-04_MJR-ICSExternalGateway-build.2 Marchen, Keith 2/25/2015";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}