$re = '/(build.\d).*$/';
$str = 'Label Owner Date
---------------------------------------------------- -------------- ----------
ICSExternalGateway-04_MJR-ICSExternalGateway-build.0 Marchen, Keith 2/25/2015
ICSExternalGateway-04_MJR-ICSExternalGateway-build.1 Marchen, Keith 2/25/2015
ICSExternalGateway-04_MJR-ICSExternalGateway-build.2 Marchen, Keith 2/25/2015';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);