re = /(build.\d).*$/
str = 'Label Owner Date
---------------------------------------------------- -------------- ----------
ICSExternalGateway-04_MJR-ICSExternalGateway-build.0 Marchen, Keith 2/25/2015
ICSExternalGateway-04_MJR-ICSExternalGateway-build.1 Marchen, Keith 2/25/2015
ICSExternalGateway-04_MJR-ICSExternalGateway-build.2 Marchen, Keith 2/25/2015'
# Print the match result
str.match(re) do |match|
puts match.to_s
end