import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(build.\\d).*$";
final String string = "Label Owner Date \n"
+ "---------------------------------------------------- -------------- ---------- \n"
+ "ICSExternalGateway-04_MJR-ICSExternalGateway-build.0 Marchen, Keith 2/25/2015 \n"
+ "ICSExternalGateway-04_MJR-ICSExternalGateway-build.1 Marchen, Keith 2/25/2015\n"
+ "ICSExternalGateway-04_MJR-ICSExternalGateway-build.2 Marchen, Keith 2/25/2015";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}