using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^name\d+\s+0x[0-9a-f]+\s+0x[0-9a-f]+\s+1\s+[1-9]\d*$";
string input = @"name0 0x3f700000 0x160000 1 0
name1 0x3f700000 0x760000 1 23";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}