package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^name\d+\s+0x[0-9a-f]+\s+0x[0-9a-f]+\s+1\s+[1-9]\d*$`)
var str = `name0 0x3f700000 0x160000 1 0
name1 0x3f700000 0x760000 1 23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}