const regex = /^name\d+\s+0x[0-9a-f]+\s+0x[0-9a-f]+\s+1\s+[1-9]\d*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^name\\d+\\s+0x[0-9a-f]+\\s+0x[0-9a-f]+\\s+1\\s+[1-9]\\d*$', 'gm')
const str = `name0 0x3f700000 0x160000 1 0
name1 0x3f700000 0x760000 1 23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}