using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"I\s+(?:\w+\s+){0,5}(TV|chocolate|fire)";
string input = @"I wish a TV
I want a b c d e f some chocolate
I need fire";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}