const regex = /I\s+(?:\w+\s+){0,5}(TV|chocolate|fire)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('I\\s+(?:\\w+\\s+){0,5}(TV|chocolate|fire)', 'gm')
const str = `I wish a TV
I want a b c d e f some chocolate
I need fire`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}