re = /I\s+(?:\w+\s+){0,5}(TV|chocolate|fire)/m
str = 'I wish a TV
I want a b c d e f some chocolate
I need fire'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end