$re = '/I\s+(?:\w+\s+){0,5}(TV|chocolate|fire)/m';
$str = 'I wish a TV
I want a b c d e f some chocolate
I need fire';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);