#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^(?=.*[a-z])|\G(?:.*?\b([A-Z]+)\b))"
Local $sString = "AB EF" & @CRLF & _
"a A 1 AB" & @CRLF & _
"ABC a" & @CRLF & _
"b ABCD a 1 ABCDE" & @CRLF & _
"AB EB "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")