const regex = /(?:^(?=.*[a-z])|\G(?:.*?\b([A-Z]+)\b))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^(?=.*[a-z])|\\G(?:.*?\\b([A-Z]+)\\b))', 'gm')
const str = `AB EF
a A 1 AB
ABC a
b ABCD a 1 ABCDE
AB EB `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}