$re = '/(?:^(?=.*[a-z])|\G(?:.*?\b([A-Z]+)\b))/m';
$str = 'AB EF
a A 1 AB
ABC a
b ABCD a 1 ABCDE
AB EB ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);