import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?=.*[a-z])|\\G(?:.*?\\b([A-Z]+)\\b))";
final String string = "AB EF\n"
+ "a A 1 AB\n"
+ "ABC a\n"
+ "b ABCD a 1 ABCDE\n"
+ "AB EB ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}